#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)\[((\w+)\b([^]]*))\]((?>(?!\[\2\b).|(?R))*)\[\/\2]"
Local $sString = "[quote quote=21555]Got some headphones, tried them, and i have sound with them.[/quote]" & @CRLF & _
"" & @CRLF & _
"[quote quote=21574]Yes speaker not working still, last night reballed audio ic, still the same, i checked the resistors you told me all ok, But U3710 speaker amp shorted! speaker was getting hot!! :) removed U3710 and U3700, but cannot reball one, as one pad is gone. are these the same as iphone 4? i know they are different numbers, but would they work?[/quote]" & @CRLF & _
""
Local $sSubst = "<blockquote$3>$4</blockquote>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)