const regex = /\[((\w+)\b([^]]*))\]((?>(?!\[\2\b).|(?R))*)\[\/\2]/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[((\\w+)\\b([^]]*))\\]((?>(?!\\[\\2\\b).|(?R))*)\\[\\\/\\2]', 'gs')
const str = `[quote quote=21555]Got some headphones, tried them, and i have sound with them.[/quote]
[quote quote=21574]Yes speaker not working still, last night reballed audio ic, still the same, i checked the resistors you told me all ok, But U3710 speaker amp shorted! speaker was getting hot!! :) removed U3710 and U3700, but cannot reball one, as one pad is gone. are these the same as iphone 4? i know they are different numbers, but would they work?[/quote]
`;
const subst = `<blockquote$3>$4</blockquote>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);