use strict;
my $str = '[quote quote=21555]Got some headphones, tried them, and i have sound with them.[/quote]
[quote quote=21574]Yes speaker not working still, last night reballed audio ic, still the same, i checked the resistors you told me all ok, But U3710 speaker amp shorted! speaker was getting hot!! :) removed U3710 and U3700, but cannot reball one, as one pad is gone. are these the same as iphone 4? i know they are different numbers, but would they work?[/quote]
';
my $regex = qr/\[((\w+)\b([^]]*))\]((?>(?!\[\2\b).|(?R))*)\[\/\2]/sp;
my $subst = '<blockquote$3>$4</blockquote>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";