$re = '/(?:\G(?!\A)|\[)[^][\s]+\K\s+/m';
$str = ' [City tier 123] [nvarchar](max) NULL,
[Counting unit] [nvarchar](max) NULL,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);