re = /(?:\G(?!\A)|\[)[^][\s]+\K\s+/m
str = ' [City tier 123] [nvarchar](max) NULL,
[Counting unit] [nvarchar](max) NULL,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end