import re
regex = re.compile(r"(?:\G(?!\A)|\[)[^][\s]+\K\s+", flags=re.MULTILINE)
test_str = (" [City tier 123] [nvarchar](max) NULL,\n"
" [Counting unit] [nvarchar](max) NULL,")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")