# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^-{2}\b[a-z][a-z\d]{2,}\b(-{1}[a-z\d]+)*$//gm;t' <<< "--valid
--th1s-is-also-val1d
--match-this-option-as-well
--9this-is-invalid-because-of-the-leading-digit
--this--is--invalid--because--of--word--wrapping--by--multiple--hyphens
--this-should-also-fail-because-of-the-trailing-hyphen-
-A -g -1 -Ag1 --valid --th1s-is-also-val1d --match-this-option-as-well --9this-is-invalid-because-of-the-leading-digit --this--is--invalid--because--of--word--wrapping--by--multiple--hyphens --this-should-also-fail-because-of-the-trailing-hyphen- --load-file=\"ReAdMe2.TxT\""