# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^-{2}\b[a-z][a-z\d]{2,}\b(-{1}[a-z\d]+)*$"
test_str = ("--valid\n"
"--th1s-is-also-val1d\n"
"--match-this-option-as-well\n\n"
"--9this-is-invalid-because-of-the-leading-digit\n"
"--this--is--invalid--because--of--word--wrapping--by--multiple--hyphens\n"
"--this-should-also-fail-because-of-the-trailing-hyphen-\n\n"
"-A -g -1 -Ag1 --valid --th1s-is-also-val1d --match-this-option-as-well --9this-is-invalid-because-of-the-leading-digit --this--is--invalid--because--of--word--wrapping--by--multiple--hyphens --this-should-also-fail-because-of-the-trailing-hyphen- --load-file=\"ReAdMe2.TxT\"")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.