import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-{2}\\b[a-z][a-z\\d]{2,}\\b(-{1}[a-z\\d]+)*$";
final String string = "--valid\n"
+ "--th1s-is-also-val1d\n"
+ "--match-this-option-as-well\n\n"
+ "--9this-is-invalid-because-of-the-leading-digit\n"
+ "--this--is--invalid--because--of--word--wrapping--by--multiple--hyphens\n"
+ "--this-should-also-fail-because-of-the-trailing-hyphen-\n\n"
+ "-A -g -1 -Ag1 --valid --th1s-is-also-val1d --match-this-option-as-well --9this-is-invalid-because-of-the-leading-digit --this--is--invalid--because--of--word--wrapping--by--multiple--hyphens --this-should-also-fail-because-of-the-trailing-hyphen- --load-file=\"ReAdMe2.TxT\"";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}