package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{(.*?)\}`)
var str = `This {is|or|and} a {cat|dog|horse} for a {kid|men|women}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}