$re = '/\{(.*?)\}/';
$str = 'This {is|or|and} a {cat|dog|horse} for a {kid|men|women}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);