re = /\{(.*?)\}/
str = 'This {is|or|and} a {cat|dog|horse} for a {kid|men|women}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end