#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "="([^"<]*<[^"]*)""
Local $sString = "dit niet "dit wel" dit ook niet ="maar <dit ""en""dit ook"" & @CRLF & _
"REM dit niet "dit <wel" dit ook niet ="maar dit ""en""dit ook"" & @CRLF & _
"dit niet "dit wel" REM "maar dit ""en""dit ook""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")