package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`="([^"<]*<[^"]*)"`)
var str = `dit niet "dit wel" dit ook niet ="maar <dit ""en""dit ook"
REM dit niet "dit <wel" dit ook niet ="maar dit ""en""dit ook"
dit niet "dit wel" REM "maar dit ""en""dit ook"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}