re = /="([^"<]*<[^"]*)"/
str = 'dit niet "dit wel" dit ook niet ="maar <dit ""en""dit ook"
REM dit niet "dit <wel" dit ook niet ="maar dit ""en""dit ook"
dit niet "dit wel" REM "maar dit ""en""dit ook"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end