#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(\w+):\s*\[(.*?)\](?=,\r?\n\s*\w+:|$)"
Local $sString = "tiles:" & @CRLF & _
" [" & @CRLF & _
" [0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1,1,1,1]" & @CRLF & _
" ,[0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1,0,0,1]" & @CRLF & _
" ,[0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1,0,0,1]" & @CRLF & _
" ,[0,0,0,0,0,1,1,1,1,1,1,1,1,1,0,1,0,0,1]" & @CRLF & _
" ,[1,1,1,1,1,1,0,0,0,0,0,0,0,1,1,1,0,0,1]" & @CRLF & _
" ,[1,0,0,0,0,0,0,1,1,1,0,0,0,0,0,0,0,0,1]" & @CRLF & _
" ,[1,0,0,0,0,0,0,1,1,1,0,0,1,1,1,0,0,0,1]" & @CRLF & _
" ,[1,0,0,0,0,0,0,0,0,0,0,0,1,0,1,0,0,0,1]" & @CRLF & _
" ,[1,0,0,1,1,1,1,1,1,1,1,1,1,0,1,0,0,0,1]" & @CRLF & _
" ,[1,0,0,0,1,0,0,0,0,0,0,0,0,0,1,1,1,1,1]" & @CRLF & _
" ,[1,0,0,0,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0]" & @CRLF & _
" ,[1,0,0,0,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0]" & @CRLF & _
" ,[1,1,1,1,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0]" & @CRLF & _
" ]," & @CRLF & _
" boxes: [" & @CRLF & _
" [5,6],[6,5],[10,5],[11,5],[16,4],[16,5],[16,6],[16,7]" & @CRLF & _
" ]," & @CRLF & _
" goals: [" & @CRLF & _
" [1,8],[1,9],[1,10],[1,11],[2,10],[2,11],[3,10],[3,11]" & @CRLF & _
" ]," & @CRLF & _
" start: [17,1]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")