# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)(\w+):\s*\[(.*?)\](?=,\r?\n\s*\w+:|$)"
test_str = ("tiles:\n"
" [\n"
" [0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1,1,1,1]\n"
" ,[0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1,0,0,1]\n"
" ,[0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1,0,0,1]\n"
" ,[0,0,0,0,0,1,1,1,1,1,1,1,1,1,0,1,0,0,1]\n"
" ,[1,1,1,1,1,1,0,0,0,0,0,0,0,1,1,1,0,0,1]\n"
" ,[1,0,0,0,0,0,0,1,1,1,0,0,0,0,0,0,0,0,1]\n"
" ,[1,0,0,0,0,0,0,1,1,1,0,0,1,1,1,0,0,0,1]\n"
" ,[1,0,0,0,0,0,0,0,0,0,0,0,1,0,1,0,0,0,1]\n"
" ,[1,0,0,1,1,1,1,1,1,1,1,1,1,0,1,0,0,0,1]\n"
" ,[1,0,0,0,1,0,0,0,0,0,0,0,0,0,1,1,1,1,1]\n"
" ,[1,0,0,0,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0]\n"
" ,[1,0,0,0,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0]\n"
" ,[1,1,1,1,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0]\n"
" ],\n"
" boxes: [\n"
" [5,6],[6,5],[10,5],[11,5],[16,4],[16,5],[16,6],[16,7]\n"
" ],\n"
" goals: [\n"
" [1,8],[1,9],[1,10],[1,11],[2,10],[2,11],[3,10],[3,11]\n"
" ],\n"
" start: [17,1]")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.