import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(\\w+):\\s*\\[(.*?)\\](?=,\\r?\\n\\s*\\w+:|$)";
final String string = "tiles:\n"
+ " [\n"
+ " [0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1,1,1,1]\n"
+ " ,[0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1,0,0,1]\n"
+ " ,[0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1,0,0,1]\n"
+ " ,[0,0,0,0,0,1,1,1,1,1,1,1,1,1,0,1,0,0,1]\n"
+ " ,[1,1,1,1,1,1,0,0,0,0,0,0,0,1,1,1,0,0,1]\n"
+ " ,[1,0,0,0,0,0,0,1,1,1,0,0,0,0,0,0,0,0,1]\n"
+ " ,[1,0,0,0,0,0,0,1,1,1,0,0,1,1,1,0,0,0,1]\n"
+ " ,[1,0,0,0,0,0,0,0,0,0,0,0,1,0,1,0,0,0,1]\n"
+ " ,[1,0,0,1,1,1,1,1,1,1,1,1,1,0,1,0,0,0,1]\n"
+ " ,[1,0,0,0,1,0,0,0,0,0,0,0,0,0,1,1,1,1,1]\n"
+ " ,[1,0,0,0,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0]\n"
+ " ,[1,0,0,0,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0]\n"
+ " ,[1,1,1,1,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0]\n"
+ " ],\n"
+ " boxes: [\n"
+ " [5,6],[6,5],[10,5],[11,5],[16,4],[16,5],[16,6],[16,7]\n"
+ " ],\n"
+ " goals: [\n"
+ " [1,8],[1,9],[1,10],[1,11],[2,10],[2,11],[3,10],[3,11]\n"
+ " ],\n"
+ " start: [17,1]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}