import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\\\\\\\)\\d+(?= +\\\\\\\\\\d+$)";
final String string = "\\\\0101 \\\\0102 \\\\0103 \\\\0104\n"
+ "\\\\0201 \\\\0202 \\\\0203 \\\\0204 \\\\0205 \\\\0206\n"
+ "\\\\0301 \\\\0302 \\\\0303 \\\\0304 \\\\0305 \\\\0306";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}