$re = '/(?<=\\\\\\\\)\d+(?= +\\\\\\\\\d+$)/m';
$str = '\\\\0101 \\\\0102 \\\\0103 \\\\0104
\\\\0201 \\\\0202 \\\\0203 \\\\0204 \\\\0205 \\\\0206
\\\\0301 \\\\0302 \\\\0303 \\\\0304 \\\\0305 \\\\0306';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);