const regex = /(?<=\\\\)\d+(?= +\\\\\d+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\\\\\\\)\\d+(?= +\\\\\\\\\\d+$)', 'gm')
const str = `\\\\0101 \\\\0102 \\\\0103 \\\\0104
\\\\0201 \\\\0202 \\\\0203 \\\\0204 \\\\0205 \\\\0206
\\\\0301 \\\\0302 \\\\0303 \\\\0304 \\\\0305 \\\\0306`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}