using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<="")[23]{1,7}(?="")";
string input = @"""3""sca""""co""1""str""0""ctor""r""3""t""0""r""1""locat""5""o""133""0""27""754a49b393c2a0""33""b97""332""cb7""3""c3c07""2""co""1""str""0""ct""233223322""or""r""3""t""0""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}