# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\")[23]{1,7}(?=\")"
test_str = "\"3\"sca\"\"\"co\"1\"str\"0\"ctor\"\"r\"3\"t\"0\"r\"1\"\"locat\"5\"o\"133\"\"0\"27\"\"754a49b393c2a0\"33\"b97\"332\"cb7\"3\"c3c07\"2\"\"co\"1\"str\"0\"ct\"233223322\"or\"\"r\"3\"t\"0\""
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.