re = /^.*(\((?:[0-1]?[0-9]|2[0-3]):[0-5][0-9]\)).*/m
str = 'Programming robots (15:32)
Understanding ROS (8:20)'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result