// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*(\((?:[0-1]?[0-9]|2[0-3]):[0-5][0-9]\)).*").unwrap();
let string = "Programming robots (15:32)
Understanding ROS (8:20)";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}