package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^url\(['"]?([^)]+?)['"]?\)$`)
var str = `url(sdaddasd)
url('sadasdas')
url("sddSDs")
url(dasdasd')`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}