$re = '/^url\([\'"]?([^)]+?)[\'"]?\)$/m';
$str = 'url(sdaddasd)
url(\'sadasdas\')
url("sddSDs")
url(dasdasd\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);