re = /^url\(['"]?([^)]+?)['"]?\)$/m
str = 'url(sdaddasd)
url(\'sadasdas\')
url("sddSDs")
url(dasdasd\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end