import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<ca>(.*?)<\\/ca>|<cert>(.*?)<\\/cert>";
final String string = "Internal Auto-Configured Settings File\n"
+ "________________________________________\n"
+ "(( Do not attempt to edit it manually ))\n"
+ "________________________________________\n"
+ "# Saved certifications:\n"
+ "<ca>\n"
+ "Text which I want to extract\n"
+ "</ca>\n"
+ "...\n"
+ "<cert>Another text I want to extract</cert>\n"
+ "...";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}