import re
regex = re.compile(r"<ca>(.*?)<\/ca>|<cert>(.*?)<\/cert>", flags=re.DOTALL)
test_str = ("Internal Auto-Configured Settings File\n"
"________________________________________\n"
"(( Do not attempt to edit it manually ))\n"
"________________________________________\n"
"# Saved certifications:\n"
"<ca>\n"
"Text which I want to extract\n"
"</ca>\n"
"...\n"
"<cert>Another text I want to extract</cert>\n"
"...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")