re = /<ca>(.*?)<\/ca>|<cert>(.*?)<\/cert>/
str = 'Internal Auto-Configured Settings File
________________________________________
(( Do not attempt to edit it manually ))
________________________________________
# Saved certifications:
<ca>
Text which I want to extract
</ca>
...
<cert>Another text I want to extract</cert>
...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end