# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(french[\s\S]*?)/<center>$1<\/centre>/;t' <<< "I am a boy with french - Glukker Man"