$re = '/(french[\s\S]*?)/';
$str = 'I am a boy with french - Glukker Man';
$subst = "<center>$1</centre>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;