use strict;
my $str = 'I am a boy with french - Glukker Man';
my $regex = qr/(french[\s\S]*?)/p;
my $subst = '<center>$1</centre>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";