#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "##([^#]*)##"
Local $sString = "Hello there ##NAME##, you have ##ORDERSNUM## orders pending."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)