$re = '/##([^#]*)##/';
$str = 'Hello there ##NAME##, you have ##ORDERSNUM## orders pending.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;