re = /##([^#]*)##/
str = 'Hello there ##NAME##, you have ##ORDERSNUM## orders pending.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result