$re = '/^WoWScrnShot_(?P<month>\d{2})(?P<day>\d{2})(?P<year>\d{2})_(?P<hour>\d{2})(?P<minute>\d{2})(?P<second>\d{2})\.jpg$/';
$str = 'WoWScrnShot_120212_235739.jpg';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);