// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^WoWScrnShot_(?P<month>\d{2})(?P<day>\d{2})(?P<year>\d{2})_(?P<hour>\d{2})(?P<minute>\d{2})(?P<second>\d{2})\.jpg$").unwrap();
let string = "WoWScrnShot_120212_235739.jpg";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}