import Foundation
let pattern = #"^WoWScrnShot_(?P<month>\d{2})(?P<day>\d{2})(?P<year>\d{2})_(?P<hour>\d{2})(?P<minute>\d{2})(?P<second>\d{2})\.jpg$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"WoWScrnShot_120212_235739.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}