package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#.*\btester\b|\b(tester)\b`)
var str = `tester, #tester
test tester # test tester
tester`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}