re = /#.*\btester\b|\b(tester)\b/
str = 'tester, #tester
test tester # test tester
tester'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end