#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bhref=\s*"\K[^"]*www\.aliexpress\.com[^"]*"
Local $sString = "<a href="http://www.aliexpress.com/af/category/200118006.html?spm=2114.030010108.0.774.bcoKC8&isAffiliate=y&g=y">Parkas</a> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")