$re = '/\bhref=\s*"\K[^"]*www\.aliexpress\.com[^"]*/';
$str = '<a href="http://www.aliexpress.com/af/category/200118006.html?spm=2114.030010108.0.774.bcoKC8&isAffiliate=y&g=y">Parkas</a> ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);