const regex = /\bhref=\s*"\K[^"]*www\.aliexpress\.com[^"]*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bhref=\\s*"\\K[^"]*www\\.aliexpress\\.com[^"]*', '')
const str = `<a href="http://www.aliexpress.com/af/category/200118006.html?spm=2114.030010108.0.774.bcoKC8&isAffiliate=y&g=y">Parkas</a> `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}