using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$[\w]* = new [\w]*;";
string input = @"public function Edit() {
if ($_POST != null) {
$result = array();
if ($_POST[""Count""] > 0) {
$Period = new period;
$Period -> GetByKey($_POST[""ID""]);
$Period -> SetArrayToValue($_POST);
$Period -> Save();
$result[""status""] = 1;
} else {
$result[""status""] = 0;
}
echo json_encode($result);
} else {
return $this -> View();
}
}
private function aaa(){
}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}