import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$[\\w]* = new [\\w]*;";
final String string = "public function Edit() {\n"
+ "if ($_POST != null) {\n"
+ " $result = array();\n"
+ " if ($_POST[\"Count\"] > 0) {\n"
+ " $Period = new period;\n"
+ " $Period -> GetByKey($_POST[\"ID\"]);\n"
+ " $Period -> SetArrayToValue($_POST);\n"
+ " $Period -> Save();\n"
+ " $result[\"status\"] = 1;\n"
+ " } else {\n"
+ " $result[\"status\"] = 0;\n"
+ " }\n"
+ " echo json_encode($result);\n"
+ " } else {\n"
+ " return $this -> View();\n"
+ " }\n"
+ " }\n\n"
+ "private function aaa(){\n\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}