$re = '/\$[\w]* = new [\w]*;/';
$str = 'public function Edit() {
if ($_POST != null) {
$result = array();
if ($_POST["Count"] > 0) {
$Period = new period;
$Period -> GetByKey($_POST["ID"]);
$Period -> SetArrayToValue($_POST);
$Period -> Save();
$result["status"] = 1;
} else {
$result["status"] = 0;
}
echo json_encode($result);
} else {
return $this -> View();
}
}
private function aaa(){
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);