import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1-9][0-9]{0,3}$";
final String string = "0100\n"
+ "0001\n"
+ "0050\n"
+ "1020\n"
+ "1000\n"
+ "9129\n"
+ "abcd\n"
+ "123x\n"
+ "1234\n"
+ "0\n"
+ "1\n"
+ "12\n"
+ "999\n"
+ "099";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}