$re = '/^[1-9][0-9]{0,3}$/m';
$str = '0100
0001
0050
1020
1000
9129
abcd
123x
1234
0
1
12
999
099';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);